Perl Modules

Most Perl modules are written in Perl, some use XS (they are written in C) so require a C compiler. Modules may have dependencies on other modules (almost always on CPAN) and cannot be installed without them (or without a specific version of them). Many modules on CPAN now require a recent version of Perl (version 5.8 or above).

How to install modules

There are several methods you can use, see the Installing Perl Modules page.

How to find modules

How to contribute

Other useful sites

Questions about the modules? Please contact the module author directly. Corrections? Additions? Suggestions? Please contact Other questions? See the CPAN FAQ.